Latest Incidents
- Unresolved
Live Services Disruption
Persistent Universe Electronic AccessDegraded PerformanceDuring the remainder of Invictus Launch Week, players can expect brief periods of degraded performance in-game.
These issues will most commonly present in the form of sluggish ASOP, Inventory, and Shop screens.
The team has been investigating a number of potential issues that can prevent players from successfully making it into the game. A hotfix to address some of these issues will roll out within the next 24 hours.
More information about Known Issues can be found on the RSI Knowledge Base
Players experiencing issues that are not tracked in the Known Issues page are advised to report the problems they're experiencing on the RSI Issue-Council
[2023-05-22 Updates]
0420 UTC - General update.
[2023-05-19 Updates]
1925 UTC - Initial Notice, mitigation in-progress. -
-
- Resolved
Platform Services Disruption
PlatformPartial OutageWe are currently investigating an outage on the RSI Platform.
This outage can prevent access to the RSI Website, Pledge Store, Spectrum, and Authentication Services for some users.
[2023-05-19 Updates]
1805 UTC - Initial Notice, investigation in-progress.
1808 UTC - Mitigation applied, team will continue to monitor.ResolvedLive Services Disruption
Persistent Universe Electronic AccessDegraded PerformanceWe are currently investigating an issue preventing players from establishing connections to available shards.
[2023-05-19 Updates]
0030 UTC - Initial Notice, team is investigating.
0045 UTC - Infrastructure is recovering.
0140 UTC - Matchmaking is temporarily disabled to accelerate infrastructure recovery.
0221 UTC - Matchmaking re-enabled.
0245 UTC - Reducing severity of incident while the team continues to monitor. -
-
- Resolved
Live Deployment
Persistent Universe Electronic AccessUnder Maintenance🚀 We have deployed Star Citizen Alpha 3.19.0-live.8478820 at 0005 UTC.
Players currently in 3.18.2 will be disconnected in ~60 Minutes. -